生命不息
折腾不止

Vestacp升级php5.5或php5.6错误解决办法

Vestacp升级php5.5或php5.6天蝎之前发过一篇博文,博文地址是:https://www.wangjunwei.com/Vestacp/21.html

但是在实际使用中,会出现下面一个问题。

代码 (Text):
—> Package php-pspell.x86_64 0:5.5.26-1.el6.remi will be an update
—> Package php-recode.x86_64 0:5.4.42-1.el6.remi will be updated
—> Package php-recode.x86_64 0:5.5.26-1.el6.remi will be an update
–> Finished Dependency Resolution
Error: Package: php-gd-5.5.26-1.el6.remi.x86_64 (remi-php55)
Requires: libgd.so.3()(64bit)
Error: Package: php-gd-5.5.26-1.el6.remi.x86_64 (remi-php55)
Requires: gd-last(x86-64) >= 2.1.1
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

解决这一问题后才能正确安装和升级php版本
如何解决这一问题呢,分析错误原因是因为GD库的关系。运行下面这个命令就可以轻松解决:

代码 (Text):
yum –enablerepo=remi install gd-last -y

好了,现在可以参照前面帖子的教程进行php版本升级了。

 

赞(0) 赞赏
版权声明:本文采用知识共享 署名4.0国际许可协议 [BY-NC-SA] 进行授权,转载请联系作者。
文章名称:《Vestacp升级php5.5或php5.6错误解决办法》
文章链接:https://wangjunwei.com/website/vestacp/22.html
本站资源仅供个人学习交流,请于下载后24小时内删除,不允许用于商业用途,否则法律问题自行承担。

评论 2

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
  1. #1

    意思是先执行这条命令,再去上一篇文章从第一步开始升级php咯?

    绅士6年前 (2016-04-28)回复
    • @绅士:执行完本文的命令,直接执行yum update php

      王俊伟6年前 (2016-04-28)回复

似水流年--王俊伟个人博客

联系博主关注我们

觉得文章有用就打赏一下文章作者

非常感谢你的打赏,我们将继续给力更多优质内容,让我们一起创建更加美好的网络世界!

微信扫一扫打赏